Degraded Performance
Incident Report for ClickFunnels
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 19:54 MDT
Update
A fix for this issue was deployed at 12:40 GMT, Sept 29th, 2020.
Posted Sep 28, 2020 - 19:53 MDT
Investigating
Our user base is currently experiencing degraded performance with Statistics on Funnel Pages. We are investigating and will post as soon as we have more information available.
Posted Sep 28, 2020 - 11:28 MDT
This incident affected: App, API, and Cloud Hosting.