Latency with Broadcasts
Incident Report for ClickFunnels
Resolved
This incident has been resolved.
Posted May 22, 2020 - 17:30 MDT
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 17:30 MDT
Investigating
We are currently investigating higher than normal latency when sending mail for some users.
Posted May 22, 2020 - 17:05 MDT
This incident affected: App.