Issues with Broadcast Emails
Incident Report for ClickFunnels Classic
Resolved
Fix has been applied and Broadcasts are sending again.
Posted May 09, 2020 - 16:10 MDT
Identified
An issue has been identified were broadcasts are not sending out for customers. We are currently working on a fix and will have updates on progress as we implement the fix.
Posted May 09, 2020 - 13:48 MDT
This incident affected: App.