Partial Outage of Funnel Pages
Incident Report for ClickFunnels
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 13:58 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 23, 2021 - 11:41 MDT
Investigating
We are currently investigating this issue.
Posted Aug 23, 2021 - 11:17 MDT
This incident affected: Funnel Pages.