We are currently experiencing issues with our DNS provider CloudFlare
Incident Report for ClickFunnels Classic
Resolved
CloudFlare has found and fixed the issue.
Posted Jul 17, 2020 - 15:39 MDT
Investigating
CloudFlare is currently experiencing issues. We will update as soon as we know more
Posted Jul 17, 2020 - 15:22 MDT
This incident affected: App, Funnel Pages, and API.