Comcast Outage
Incident Report for ClickFunnels
Resolved
This incident has been resolved.
Posted 13 days ago. Nov 06, 2017 - 13:58 MST
Update
If you're on Comcast and can't even get outage reporting sites to load try Twitter for up to date status:
https://twitter.com/search?vertical=default&q=comcast%20outage&src=typd

https://twitter.com/DownStatus/status/927608632593629184
Posted 13 days ago. Nov 06, 2017 - 11:49 MST
Monitoring
Comcast is currently suffering from a major outage which affects loading of parts of ClickFunnels.com and millions of other sites when connecting from a Comcast Xfinity Internet Connection... http://outage.report/xfinity
Posted 13 days ago. Nov 06, 2017 - 11:35 MST