Delayed Page Updates
Incident Report for ClickFunnels Classic
Resolved
This incident has been resolved.
Posted Apr 03, 2020 - 09:55 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2020 - 06:09 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2020 - 06:09 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 31, 2020 - 22:24 MDT
Identified
Updates to funnel pages may take up to 5 minutes to show changes after saving.
Posted Mar 31, 2020 - 12:35 MDT
This incident affected: Funnel Pages.