Delays in SSL Provisioning
Incident Report for ClickFunnels
Resolved
CloudFlare has resolved this issue.
Posted 5 months ago. Dec 12, 2017 - 14:49 MST
Identified
CloudFlare is experiencing delays with SSL Certificate provisioning which is affecting ClickFunnels users as well.

Follow CloudFlare issue status here: https://www.cloudflarestatus.com/incidents/16bpy8850sr4
Posted 5 months ago. Dec 12, 2017 - 13:32 MST