Increased response times
Incident Report for ClickFunnels
Resolved
Response times remain at normal levels. This is incident has been resolved.
Posted Apr 23, 2019 - 12:12 MDT
Monitoring
Response times have returned to normal at this time. We are continuing to monitor.
Posted Apr 23, 2019 - 12:07 MDT
Investigating
We are currently investigating increased response times on the Clickfunnels platform.
Posted Apr 23, 2019 - 11:57 MDT
This incident affected: App.