Delays in Domain Setup Process
Incident Report for ClickFunnels
Resolved
Delays with adding new domains have been resolved.
Posted 13 days ago. Nov 06, 2017 - 14:48 MST
Identified
We've identified delays in new domain setup process and are working with upstream provider on a resolution.
Posted 13 days ago. Nov 06, 2017 - 13:59 MST